menu
Noen deler av denne siden har ikke blitt oversatt enda, vi beklager for det inntrufnet
Ofte stilte spørsmål

General Issues | Enterprise License | cPanel | Plesk | DirectAdmin | ISPmanager

General Issues

Site.pro plugin installation guide
You will find plugin installation guide on your license page. Choose "Your Panel" and below this field you will find plugin installation guide link.

Site.pro builder installation guide
You will find builder installation guide link on your license page below "Your Panel" field.

Website builder asks to choose new template instead of showing your client website
1. Client accidentally pressed "Reset" or "Change template" button. Check if your client has manual or automatic (available for enterprise) backup enabled;
2. Client closed website builder without pressing "Save draft" after creating a website;
3. Builder server (on license page) was changed in "Builder server" field.

Site.pro logo appears in builder and template page instead of Custom Logo
1. After your Custom Logo upload on your license page, press Save button;
2. Clear Internet browser cache.

Website in builder looks different than website in a browser after publish
1. Check if wide version of your website is correct (turn it off, if not);
2. Please clear Internet browser cache
3. Check if you have changed DNS (CNAME) records for your domain to mydomain.com. CNAME X.site.pro (where "X" could be "eu", "us" or "tw" - depending on server where builder is installed (you can check that on your licence page while filling the "Custom builder domain" field).

Your own plugin creation
To create your own plugin, please use this plugin creation guide.

Site builder can't be accessed via Builder's URL.
The Site.pro website builder accessible only via your Hosting Panel or Site.pro account.

Blank page is opened instead of the builder
The reason is that the user migrated to another account in hosting panel and the username was changed. The builder thinks it is a different user and doesn't open the builder. In this case inform us and we will update the user in our system.

Preview does not work (404 error)
Builder domain is redirected to a different server (not to the builder server) and than you need to properly configure DNS record for the builder domain.

Very slow publishing and then error "Can't find destination error" or "Error creating directory", publishing gets stuck on "accessing upload dir..."
Passive mode for FTP is not enabled on your server. Please enable it and try again.

Images are not uploaded in builder (shows error, gets stuck at 100%, etc.)
Check PHP "post_max_size" value. Recommended value is 128M or higher. Increase it, if needed, and restart apache server.

FTP connection error
Only if "ping [user website domain]" command doesn't return IP of eu.site.pro - 79.98.26.232] You have to redirect your domain to "eu.site.pro" server with DNS record (either: "[domain] CNAME eu.site.pro."
If your Domain Management Panel does not support CNAME records, please configure DNS records in this way:  A  @  [Site.pro Builder IP].
Check if firewall doesn't block our builder server which you use in the license (eu.site.pro or us.site.pro or tw.site.pro).

Added DNS record of type CNAME but builder domain doesn't work
Check if you added "dot" at the end of builder domain in DNS record (it has to be not "builder.domain.com" but "builder.domain.com."). If you added it correctly try to wait for some time for a domain to propagate over the internet, it can take some hours.

Uploading image in gallery gets stuck on 100%
Check values of PHP parameters "post_max_size" and "upload_max_filesize". Recommended values are 64M for both. If they are less, uploading images/files to builder may not work properly. Increase them and try to upload an image/file again.

FTP login incorrect
This may be caused by FTP server which accepts only SSL connections. We can add your IP address to the exception list so that FTPS publication is applied. If you agree, please, let us know. As a temporary solution you can disable forced SSL connections.

Google maps error
To insert google maps to the site builder you have to do the following steps:
1. Modify config.json file by adding String googleMapsApiKey — Google.com Maps API key. Required to enable Google Maps plugin (get it from here). default: -
2. Get googleMapsApiKey from here
Use your Builder installation guide, which you find on your license page
Notice: your each client have to add API Keys for published websites in a builder by themselves (this field they find on builder in google maps properties).

Error uploading .png files
Please try to enable PHP extension "exif" and try to upload .png image again.

Enterprise License

Site.pro plugin installation guide
You will find plugin installation guide on your license page. Choose "Your Panel" and below this field you will find plugin installation guide link.

Site.pro builder installation guide
You will find builder installation guide link on your license page below "Your Panel" field.

Builder redirects to main hosting site anyway (accessing via plugin or demo URL)
During builder installation parameters "API username" and/or "API password" were set incorrectly. They are saved in file "config.json" in builder root directory - parameters "apiUsername" and "apiPassword". Values of parameters are located within your enterprise license. Please fix them (you should change all "/" to "\/" in "apiPassword")

Builder demo URL throws 404 error
.htaccess in builder is not working. Check if apache module "mod_rewrite" is turned on

Plugin throws "Error: license is required"
Click "Save" button in your license after builder installation.
If it does not solve the problem make sure your builder domain is resolved. Configure DNS for your builder domain to make it point to your builder installation and wait for a while for new DNS configuration to be propagated over the internet.
Also check if firewall does not block connection from site.pro server on port 80 during license synchronization.

Builder throws 403 error
You need to clicked "Save" button in your Enterprise license. Also note that you can open builder only via public demo URL or via plugin in your hosting panel.

Builder demo URL throws 403 error
Please check builder files owner and group. If you extracted builder archive from SSH terminal being logged in as root then you need to chown files to a correct user and group.

Enterprise license Builder - 500 Internal Error
This error occurs when client doesn't click Save in his license after builder installation and use a whole domain (not subdomain) as a builder domain.

When SitePro builder plugin icon is not visible in cPanels "paper_lantern" theme (even after user set icon in his builder license and updated plugin)
cPanel installation uses custom style for "paper_lantern" theme (this can be verified by lookin to folder "/var/cpanel/customizations/styled/" what will contain folders with style name). To solve this issue call this command: "/usr/local/cpanel/bin/sprite_generator --theme paper_lantern --style [style_name] --verbose" as root in server cPanel is installed ("[style_name]" in this command needs to be replaced with a name of a style folder you want to fix).

Passive mode error with using together with SSL
cPanel blocs connections coming from builder for incompatibility related issues. Try to enable "Broken Clients Compatibility" option in FTP configuration within WHM system. Please check if firewall doesn't block passive FTP ports when using together with SSL.

plesk

Plesk panel returns error "Error 1006 get plan data: Permission denied"
The problem should be solved with plugin re-installation

Published website suggests to download file instead of loading page in web
This is because PHP is currently working as CGI program on virtual host. To fix this log in to Plesk as admin. Edit service plan which is used by current website. Select tab "Hosting Parameters". Change "Run PHP as" to "Apache module".

Builder publishing throws "server error"
Login keys functionality is turned off in DirectAdmin. It has to be enabled by modifying a file as shown in plugin installation guide. If the problem persists after enabling login keys try to re-install the plugin.

DirectAdmin + SSL + PHP 5.6 = problems
PHP 5.6 or newer require a valid SSL certificate to connect. So the API call will fail if DA ssl cert is invalid. You can use PHP 5.5 to fix this problem.

Connection error
Please try to create login key manually:

  • go to /CMD_LOGIN_KEYS in your panel (URL)
  • click on "Create new Login Key"
  • fill in key name: "siteprobuilder", key value: [think of some 16-char code], expires: never, uses: 0, clear key: checked, allow htm: checked, commands: CMD_LOGIN and CMD_PLUGINS.
  • enter password below and click "Create".
If this operation succeeds then create a new file if it doesn't exist already:
/usr/local/directadmin/plugins/siteprobuilder/include/login_key and put there a key value you used in login key creation. Save the file.
After that if everything is succeeded then publishing to this server should start working.

Plugin throws error in ISPmanager 5
Make sure that PHP extension "curl" is turned on. Also make sure that PHP parameter "disable_functions" doesn't include function "shell_exec". If it is included then delete it from there and restart server.