FAQ

Free images used in Site.pro templates

Builder Issues

All images used in templates are CC0 licensed. You can read more here

Move website to another server

Builder Issues

1. Open builder via old Hosting Panel. Hover on Publish icon and press "Backup/Restore" item;
2. Download backup;
3. Open builder via new Hosting Panel. Select Backup/Restore, restore it;
4. Publish the website.

Site.pro plugin installation guide

Builder Issues

You will find plugin installation guide on your license page. Choose "Your Panel" and below this field you will find plugin installation guide link.

Site.pro builder installation guide (Enterprise)

Builder Issues

You will find builder installation guide link on your license page below "Your Panel" field.

Update Free license to Premium

Builder Issues

1. Create new Premium license, fill it out;
2. Assign IP;
3. Reinstall Site.pro plugin, use „Plugin installation guide“ from Premium license.

Website builder asks to choose new template instead of showing your client website

Builder Issues

1. Client accidentally pressed "Reset" or "Change template" button. Check if your client has manual or automatic (available for enterprise) backup enabled;
2. Client closed website builder without pressing "Save draft" after creating a website;
3. Builder server (on license page) was changed in "Builder server" field.

Site.pro logo appears in builder and template page instead of Custom Logo

Builder Issues

1. After your Custom Logo upload on your license page, press Save button;
2. Clear Internet browser cache.

Website in builder looks different than website in a browser after publish

Builder Issues

1. Check if wide version of your website is correct (turn it off, if not);
2. Please clear Internet browser cache
3. Check if you have changed DNS (CNAME) records for your domain to mydomain.com. CNAME X.site.pro (where "X" could be "eu", "us" or "tw" - depending on server where builder is installed (you can check that on your licence page while filling the "Custom builder domain" field).

Site builder can't be accessed via Builder's URL.

Builder Issues

The Site.pro website builder accessible only via your Hosting Panel or Site.pro account.

Blank page is opened instead of the builder

Builder Issues

The reason is that the user migrated to another account in hosting panel and the username was changed. The builder thinks it is a different user and doesn't open the builder. In this case inform us and we will update the user in our system.

Very slow publishing and then error "Can't find destination error" or "Error creating directory", publishing gets stuck on "accessing upload dir..."

Builder Issues

Passive mode for FTP is not enabled on your server. Please enable it and try again.

Images are not uploaded in builder (shows error, gets stuck at 100%, etc.)

Builder Issues

1. Check values of PHP parameters "post_max_size" and "upload_max_filesize". Recommended values are 64M for both. If they are less, uploading images/files to builder may not work properly. Increase them and try to upload an image/file again.
2. Check PHP "post_max_size" value. Recommended value is 128M or higher. Increase it, if needed, and restart apache server.

FTP connection error

Builder Issues

The problem usually occurs due to firewall on your server which blocks connections from builder server on port 21.

For Premium license owners:
Allow connections from the following IPs on your server on ports 21, 80 and all ports which you have configured for passive FTP connections:
- 109.235.65.18
- 79.98.26.232
- 104.196.132.63
- 104.199.204.141
- 188.225.9.184
All these IPs can be used for builder opening.

Added DNS record of type CNAME but builder domain doesn't work

Builder Issues

Check if you added "dot" at the end of builder domain in DNS record (it has to be not "builder.domain.com" but "builder.domain.com."). If you added it correctly try to wait for some time for a domain to propagate over the internet, it may take several hours.

FTP login incorrect

Builder Issues

This may be caused by FTP server which accepts only SSL connections.
Only for Premium license:
We can add your IP address to the exception list so that FTPS publication is applied. If you agree, please, let us know. As a temporary solution you can disable forced SSL connections.

Error uploading .png files

Builder Issues

Please try to enable PHP extension "exif" and try to upload .png image again.

Site.pro badge instead of your logo

Builder Issues

After license upgrade, Site.pro badge is still displayed on websites. Your logo is starting to be displayed only on newly created websites.

Choosing different server in your license

Builder Issues

Choose the old one first and write to support@site.pro or create a ticket after log in to migrate your clients to a new server.

E-mail and MX records

Builder Issues

If you want to have website builder and mail server on the same domain, you need to add MX records to that domain (pointing to your mail server IP address).

Your own plugin creation

Builder Issues

To create your own plugin, please use this plugin creation guide.

Could not connect to Hosting API

Builder Issues
Make sure that used builder server is not blocked by firewall on your server (it is recommended to whitelist all ports: 80 and 2222).

Can I have multiple IPs on 1 server?

Builder Issues
Our pricing is based per server. But, we can not control that process, so we charge per IP.
We can make manual plans allowing you to provide a wide range of IPs for 1 server. It can be done for companies who have more than 5 servers.
Or
You can buy Site.pro directly from Plesk Panel (if you use Plesk). Plesk licensing is related to a server. So you can have multiple IPs on 1 server.

Build a website using a subdomain

Builder Issues

Subdomain should be created in the hosting panel, then your clients will have access to the builder for a new subdomain via their hosting panel.

Builder logo is not shown

Builder Issues

Possibly the license synchronization with your builder fails when you click "Save" button in the license.
To fix this problem use these methods:
Method 1:
Check whether PHP parameter "allow_url_fopen" is ON in builder hosting PHP configuration.
1. Set this parameter to ON and restart server.
2. Save Enterprise license and check if builder logo appeared (we recommend to check logo in new builder session, for example in another browser).
Method 2:
Check if API username and password which you entered during builder installation are correct.
1. Open builder file "config.json" located in builder web root folder.
2. Locate parameters "apiUsername" and "apiPassword".
3. Make sure they are the same as specified in Enterprise license.
4. Fix them if needed (if password in the license contains symbols "/" please replace it with "\/" in "config.json" file) and save the file.
5. Save Enterprise license and check if builder logo appeared.
Method 3:
Check if firewall of your builder server does not block site.pro server.
We recommend to white-list site.pro IPs from which license synchronization can be made:
109.235.65.18
104.196.132.63
104.199.204.141
Method 4:
If method 1 and method 2 did not solve the problem:
1. Open file ".htaccess" located in builder web root folder.
2. Comment line below:
RewriteRule ^(.*)$ index.php [L,QSA]
3. Uncomment line:
#RewriteRule ^(.*)$ index.php?HTTP_AUTHORIZATION=%{HTTP:Authorization} [L,QSA]
4. Save file.
5. Open file "config.json".
6. Add parameter "keepHtaccess": true somewhere in the middle and save the file.
7. Save Enterprise license and check if builder logo appeared.

FTP passive mode error

Builder Issues

Builder requires FTP passive mode enabled on your server to be able to publish websites.
If you server is behind NAT then make sure that FTP passive mode is properly configured:
use extra option "MasqueradeAddress" (for ProFTPD) or "ForcePassiveIP" (for Pure-ftpd) and specify your external IP address.

"Server error" during Save or Publish

Builder Issues

To solve this problem please take the following steps:
1. Open builder in Chrome or Firefox browser
2. Open developer tools in browser (key F12)
3. Switch to "Network" tab
4. Click on "Save" button in builder
5. Click on appeared request line (it should begin with "?sess=")
6. Switch to "Response" tab
7. Copy text you see in this tab
8. Create ticket on site.pro and tell us about "server error" and paste copied text. Our developers will fix this problem.
9. Thank you and excuse us for inconvenience.

Error loading page. Try again later.

Builder Issues

To solve this problem please take the following steps:
1. Open builder in Chrome or Firefox browser
2. Open developer tools in browser (key F12)
3. Switch to "Network" tab
4. Click on "Save" button in builder
5. Click on appeared request line (it should begin with "?sess=")
6. Switch to "Response" tab
7. Copy text you see in this tab
8. Create ticket on site.pro and tell us about "error loading page" and paste copied text. Our developers will fix this problem.
9. Thank you and excuse us for inconvenience.

Change domain for website

Builder Issues
There are two ways to change the domain name for clients without interrupting website's work:
1. Websites in the builder are saved to folder in builder file system using this pattern: "/[path to builder files]/data/[first domain character]/[second domain character]/[full domain name]" (e.g.: for domain "example.com" it would be: "/[path to builder files]/data/e/x/example.com"). So, to change the domain you will only need to move its files to a new folder;
2. For this option you will need to implement custom builder plugin (using our Custom Plugin API) for hosting panel/billing system you are using (information on how to do it you can find in your builder license by choosing "Custom (API)" in "Your Panel" section and clicking link "API for plugin" under it).

To make domain name changing possible, when implementing custom plugin you will need to do these steps:
a) pass client websites unique ID to "domain" property (e.g.: if users ID is 251 and websites ID is 327, pass "u251-w327.id" to "domain" property);
b) pass actual (current) domain name to property "baseDomain" (this property is undocumented, but you just pass the domain as string to it);
This will make that your user websites will be identified by unchanging identifier, independent from the domain name, and will allow you to change it.

"googleFontsApiKey is not set"

Builder Issues

In order to fix this problem just create API key from Google by going to this link https://developers.google.com/fonts/docs/developer_api and put key in file "config.json" located in builder web root folder - you need to set it to parameter "googleFontsApiKey".

Note. Most probably Google Maps widget also does not work in your builder. To make it working do the same as for Google Fonts but use this link for key creation https://developers.google.com/maps/documentation/javascript/get-api-key and parameter "googleMapsApiKey" in file "config.json".