ამ გვერდის ზოგიერთი ნაწილი არ გადაითარგმნა, ბოდიში უხერხულობისთვის
FAQ

Free images used in Site.pro templates

Builder Issues

All images used in templates are CC0 licensed. You can read more here

Move website to another server

Builder Issues

1. Open builder via old Hosting Panel. Hover on Publish icon and press "Backup/Restore" item;
2. Download backup;
3. Open builder via new Hosting Panel. Select Backup/Restore, restore it;
4. Publish the website.

Site.pro plugin installation guide

Builder Issues

You will find plugin installation guide on your license page. Choose "Your Panel" and below this field you will find plugin installation guide link.

Site.pro builder installation guide (Enterprise)

Builder Issues

You will find builder installation guide link on your license page below "Your Panel" field.

Update Free license to Premium

Builder Issues

1. Create new Premium license, fill it out;
2. Assign IP;
3. Reinstall Site.pro plugin, use „Plugin installation guide“ from Premium license.

Website builder asks to choose new template instead of showing your client website

Builder Issues

1. Client accidentally pressed "Reset" or "Change template" button. Check if your client has manual or automatic (available for enterprise) backup enabled;
2. Client closed website builder without pressing "Save draft" after creating a website;
3. Builder server (on license page) was changed in "Builder server" field.

Site.pro logo appears in builder and template page instead of Custom Logo

Builder Issues

1. After your Custom Logo upload on your license page, press Save button;
2. Clear Internet browser cache.

Website in builder looks different than website in a browser after publish

Builder Issues

1. Check if wide version of your website is correct (turn it off, if not);
2. Please clear Internet browser cache
3. Check if you have changed DNS (CNAME) records for your domain to mydomain.com. CNAME X.site.pro (where "X" could be "eu", "us" or "tw" - depending on server where builder is installed (you can check that on your licence page while filling the "Custom builder domain" field).

Site builder can't be accessed via Builder's URL.

Builder Issues

The Site.pro website builder accessible only via your Hosting Panel or Site.pro account.

Blank page is opened instead of the builder

Builder Issues

The reason is that the user migrated to another account in hosting panel and the username was changed. The builder thinks it is a different user and doesn't open the builder. In this case inform us and we will update the user in our system.

Preview does not work (404 error)

Builder Issues

Builder domain is redirected to a different server (not to the builder server) and than you need to properly configure DNS record for the builder domain.

Very slow publishing and then error "Can't find destination error" or "Error creating directory", publishing gets stuck on "accessing upload dir..."

Builder Issues

Passive mode for FTP is not enabled on your server. Please enable it and try again.

Images are not uploaded in builder (shows error, gets stuck at 100%, etc.)

Builder Issues

1. Check values of PHP parameters "post_max_size" and "upload_max_filesize". Recommended values are 64M for both. If they are less, uploading images/files to builder may not work properly. Increase them and try to upload an image/file again.
2. Check PHP "post_max_size" value. Recommended value is 128M or higher. Increase it, if needed, and restart apache server.

FTP connection error

Builder Issues

Only if "ping [user website domain]" command doesn't return IP of eu.site.pro - 79.98.26.232] You have to redirect your domain to "eu.site.pro" server with DNS record (either: "[domain] CNAME eu.site.pro."
If your Domain Management Panel does not support CNAME records, please configure DNS records in this way:  A  @  [Site.pro Builder IP].
Check if firewall doesn't block our builder server which you use in the license (eu.site.pro or us.site.pro or tw.site.pro).

Added DNS record of type CNAME but builder domain doesn't work

Builder Issues

Check if you added "dot" at the end of builder domain in DNS record (it has to be not "builder.domain.com" but "builder.domain.com."). If you added it correctly try to wait for some time for a domain to propagate over the internet, it may take several hours.

FTP login incorrect

Builder Issues

This may be caused by FTP server which accepts only SSL connections. We can add your IP address to the exception list so that FTPS publication is applied. If you agree, please, let us know. As a temporary solution you can disable forced SSL connections.

Error uploading .png files

Builder Issues

Please try to enable PHP extension "exif" and try to upload .png image again.

Site.pro badge instead of your logo

Builder Issues

After license upgrade, Site.pro badge is still displayed on websites. Your logo is starting to be displayed only on newly created websites.

Choosing different server in your license

Builder Issues

Choose the old one first and write to support@site.pro or create a ticket after log in to migrate your clients to a new server.

E-mail and MX records

Builder Issues

If you want to have website builder and mail server on the same domain, you need to add MX records to that domain (pointing to your mail server IP address).

Your own plugin creation

Builder Issues

To create your own plugin, please use this plugin creation guide.

Payment is pending

Payment Issues

It means that we have no answer from the payment system yet. There could be no funds on your PayPal/Card or payment system is temporary not working. When the billing system charges you successfully - license starts working automatically.

Update Free/Premium license to Enterprise

Enterprise License

1. Create new Enterprise license, fill it out;
2. Assign IP;
3. Reinstall Site.pro plugin, use Plugin installation guide from Enterprise license;
4. Install Site.pro builder on your server. Use Builder installation guide from Enterprise license;
5. Contact support to move existing websites to your server.

Builder redirects to main hosting site anyway (accessing via plugin or demo URL)

Enterprise License

During builder installation parameters "API username" and/or "API password" were set incorrectly. They are saved in file "config.json" in builder root directory - parameters "apiUsername" and "apiPassword". Values of parameters are located within your enterprise license. Please fix them (you should change all "/" to "\/" in "apiPassword")

Google maps error

Enterprise License

To insert google maps to the site builder you have to do the following steps:
1. Insert "googleMapsApiKey" line anywhere in config.json (except inside "db" property). Ex. "googleMapsApiKey": "Your API key here"
2. Get googleMapsApiKey from here
3. You should add your domains to the list of allowed domains to use this API key. You can do it by pressing „Restrict key“ in „API key created“ pop-up.
Use your Builder installation guide, which you find on your license page.
Notice: your each client have to add API Keys for published websites in a builder by themselves (this field they find on builder in google maps properties).

Site.pro builder installation guide

Enterprise License

You will find builder installation guide link on your license page below "Your Panel" field.

Google Maps coordinates do not work

Enterprise License

Make sure that Google Maps API key which you use in file "config.json" (located in builder web root) is authorized and not restricted to use for your builder domain. You may also try to use another API key to check if this solves the problem.

Builder demo URL throws 404 error

Enterprise License

.htaccess in builder is not working. Check if apache module "mod_rewrite" is turned on.

Plugin throws "Error: license is required"

Enterprise License

Click "Save" button in your license after builder installation.
If it does not solve the problem make sure your builder domain is resolved. Configure DNS for your builder domain to make it point to your builder installation and wait for a while for new DNS configuration to be propagated over the internet.
Also check if firewall does not block connection from site.pro server on port 80 during license synchronization.

Builder throws 403 error

Enterprise License

You need to clicked "Save" button in your Enterprise license. Also note that you can open builder only via public demo URL or via plugin in your hosting panel.

Builder demo URL throws 403 error

Enterprise License

Please check builder files owner and group. If you extracted builder archive from SSH terminal being logged in as root then you need to chown files to a correct user and group.

Enterprise license Builder - 500 Internal Error

Enterprise License

This error occurs when client doesn't click Save in his license after builder installation and use a whole domain (not subdomain) as a builder domain.

Run builder under HTTPS protocol

Enterprise License
If you want to run builder under HTTPS protocol you need to do the following steps:
1. Open your enterprise license and change builder domain by adding "https://" at the beginning of it (e.x. "builder.yourdomain.com" -> "https://builder.yourdomain.com")
2. Open file "config.json" in your builder web root directory and update parameter "siteProApiUrl" by changing "http://" part to "https://"
3. Click "Save" button in your license
4. Check if builder work properly under HTTPS protocol.

Template preview throws "Notice: getimagesize(): Read error! in /home/construtor/public_html/libs/phpthumb/GdThumb.inc.php on line 0"

Enterprise License

1. Please check if PHP option "allow_url_fopen" is enabled on your server. It is required for builder.
2. After you enable it, click "Save" button in your license.
3. Check if error is gone.

Bing map error

Enterprise License

To insert Bing maps to the site builder you have to do the following steps:
1. Insert "bingMapsApiKey" line anywhere in config.json (except inside "db" property). Ex. "bingMapsApiKey": "Your API key here"
2. Get bingMapsApiKey from here
3. You should add your domains to the list of allowed domains to use this API key. You can do it by pressing „Restrict key“ in „API key created“ pop-up.
Use your Builder installation guide, which you find on your license page.
Notice: your each client have to add API Keys for published websites in a builder by themselves (this field they find on builder in Bing maps properties).

No FTP account found

cPanel

1. Possibly you have a pretty old version of plugin installed on cPanel server. It does not include functionality of automatic adding FTP accounts if needed for publication. Re-install plugin following installation instruction in your license (you need to uninstall and install it again). This should fix the problem.
2. Problem occurs when site builder cannot create FTP account when opening builder from cPanel. To fix this problem you need to ensure that you have not exceeded limit of FTP accounts in your cPanel account. Delete unused FTP accounts. There may be old FTP accounts left which were created by builder and not used anymore (they are of type "a1b2c3d4@yoursite.com"). As soon as you have space for at least one FTP account the website publication should work.

When Site.pro builder plugin icon is not visible in cPanels "paper_lantern" theme (even after user set icon in his builder license and updated plugin)

cPanel

cPanel installation uses custom style for "paper_lantern" theme (this can be verified by lookin to folder /var/cpanel/customizations/styled/ what will contain folders with style name). To solve this issue call this command: "/usr/local/cpanel/bin/sprite_generator --theme paper_lantern --style [style_name] --verbose" as root in server cPanel is installed ("[style_name]" in this command needs to be replaced with a name of a style folder you want to fix).

Passive mode error with using together with SSL

cPanel

cPanel blocs connections coming from builder for incompatibility related issues. Try to enable "Broken Clients Compatibility" option in FTP configuration within WHM system. Please check if firewall doesn't block passive FTP ports when using together with SSL.

Plesk panel returns error "Error 1006 get plan data: Permission denied"

Plesk

The problem should be solved with plugin re-installation.

Published website suggests to download file instead of loading page in web

Plesk

This is because PHP is currently working as CGI program on virtual host. To fix this log in to Plesk as admin. Edit service plan which is used by current website. Select tab "Hosting Parameters". Change "Run PHP as" to "Apache module".

Plugin for Plesk, Plesk Onyx

Plesk

Site.pro provides plugins from Plesk 12 (and higher) till Plesk Onyx.

Plugin icon and name is reset to default of Site.pro

Plesk

To solve this problem please re-install the plugin on your Plesk server downloading new plugin from your license which you use on site.pro. It will return back your icon and title and the plugin overwriting should never happen again.
Please note that this action is absolutely safe - it will not affect clients websites.

Builder publishing throws "server error"

DirectAdmin

Login keys functionality is turned off in DirectAdmin. It has to be enabled by modifying a file as shown in plugin installation guide. If the problem persists after enabling login keys try to re-install the plugin.

DirectAdmin + SSL + PHP 5.6 = problems

DirectAdmin

PHP 5.6 or newer require a valid SSL certificate to connect. So the API call will fail if DA SSL cert is invalid. You can use PHP 5.5 to fix this problem.

Connection error

DirectAdmin
Please try to create login key manually:
  • go to /CMD_LOGIN_KEYS in your panel (URL)
  • click on "Create new Login Key"
  • fill in key name: "siteprobuilder", key value: [think of some 16-char code], expires: never, uses: 0, clear key: checked, allow htm: checked, commands: CMD_LOGIN and CMD_PLUGINS.
  • enter password below and click "Create".
If this operation succeeds then create a new file if it doesn't exist already:
/usr/local/directadmin/plugins/siteprobuilder/include/login_key and put there a key value you used in login key creation. Save the file.
After that if everything is succeeded then publishing to this server should start working.

Plugin throws error in ISPmanager 5

ISPmanager

Make sure that PHP extension "curl" is turned on. Also make sure that PHP parameter "disable_functions" doesn't include function "shell_exec". If it is included then delete it from there and restart server.

Site.pro plugin for ISPmanager 5

ISPmanager

Site.pro provides plugin for ISPmanager 5. Site.pro does not provide/support plugin for ISPmanager4.